Detailed tiles never display

Aug 31, 2009 at 4:57 AM

Hi

I've been trying to get this control going for a project I have to do, but I haven't been able to get Virtual Earth to download anything even after I zoom in. All I get is a very blurry version of the images for the entire earth. This happens in the sample application as well as in a separate project I've been building. It also does the same thing in the control from vewpf.codeplex.com, so it's not isolated to the InfoStrat control (but this is the one I want to use in the long run).

Am I missing something really basic? I have the latest version of Virtual Earth (Bing Maps 3D), and I have the Win 7 RTM x64 version with IE8. Not sure if that has any bearing on things.

Thanks for any help,
a very stuck Andrew

Coordinator
Aug 31, 2009 at 7:19 AM

Andrew,

I assume you have opened Bing Map 3D in your browser and zoomed around to see if it is your computer or internet connection?

Have you tried it on a different computer?

Aug 31, 2009 at 7:38 AM
Edited Aug 31, 2009 at 7:42 AM
Yep, I tried it in IE and it worked fine. I get the same result on a different work machine (Win Vista with IE 7), as well as my home machine, so I don't think it's my net connection either.
 
Interestingly, in IE7 on Vista you can only have one 3D map at a time, but in IE8 on Win7 I can have as many as I want.
Aug 31, 2009 at 9:07 AM

Sorry to bother you, it seems to be a problem with the fwlinks from Microsoft. If I run Virtual Earth from the browser, it works fine, but running it from anywhere else has problems. I assume the Virtual Earth website has some backup links in case something isn't found. Anyway, I had issues with the installer too so I think Microsofts links require fixing if they are being hit from Western Australia.

I managed to fix the issue by going through a proxy and saving these files onto a local web server:

Road:  http://go.microsoft.com/fwlink/?LinkID=98770
Aerial:  http://go.microsoft.com/fwlink/?LinkID=98771
Hybrid:  http://go.microsoft.com/fwlink/?LinkID=98772
DEM:  http://go.microsoft.com/fwlink/?LinkID=98774
Models:  http://go.microsoft.com/fwlink/?LinkID=98775

How strange!