Cannot create instance of 'SurfaceVEMap'

May 19, 2009 at 2:51 PM
Edited May 19, 2009 at 3:09 PM

Hi guys,

I'm having some problems during the initialization of the control.
Yesterday everything worked like a charm, and today I'm getting this error message when I to try to run my application.

Cannot create instance of 'SurfaceVEMap' defined in assembly 'InfoStrat.VE.NUI, Version=1.0.0.0,
Culture=neutral, PublicKeyToken=4b91201fe2ccb763'. Exception has been thrown by the target of an invocation. 
Error at object 'System.Windows.Controls.Grid' in markup file.

Does anyone have a solution or an explanation for this? I bet when Ill try it tomorrow everything will be
working fine (I had a similair problem before). But I don't want to risk a crash like this during a demo.

It's going wrong at:
public SurfaceWindow1()
{

// I get the error message here
InitializeComponent();

// Add handlers for Application activation events
AddActivationHandlers();
}

I tried to create a new project, with nothing but the SurfaceVEMap, and it still does'nt work.
If someone could help me out, I would really appreciate it.

Cheers,

Toner.

Edit: I'm gonna check if it's because we installed an older version of Virtual Earth.
I'll keep you guys posted.

 

Coordinator
May 19, 2009 at 7:15 PM

When that error occurs, check the inner exception in the exception window and keep going to the inner exception until you see what the source exception is.  Have you made any modifications to the source?

The wrong version of VE can do that as well.

May 21, 2009 at 9:10 AM
Edited May 21, 2009 at 9:56 AM

Hi Josh,

A colleague of mine installed an older version of Virtual Earth (for demo purposes) without telling me.
So false alarm from my side, this topic can be closed/deleted. Sorry bout this.

Coordinator
May 21, 2009 at 4:57 PM

Thanks for the follow up.