DoMapMove doesn't work properly on ManipulationProcessorManipulationDelta with 3DMap

Mar 15, 2010 at 1:41 PM

I have a problem with a touch screen, when I use the map with 3D. It starts behaving very extrange. I'm not sure what i could be.

I'm not getting any error. It looks like the panning is messing with the altitude and the panning is not right because of the buildings.

Is it possible get a bit of help, I'm checking the function DoMapMove, but I haven't found anything representative, probably because I'm new with this framework.

 

Thanks in advance, I would appreciate some help with this subject.

 

Regards,

Leonardo

Coordinator
Mar 26, 2010 at 5:10 AM

Try getting the latest source code drop from the source code tab. I fixed a few odd things in the latest drop so I want to make sure I didn't already fix the problem you're experiencing.

Panning near buildings is affected on purpose so you don't go into the building.

What type of touchscreen do you have? Are you having the pan/altitude problem just on one computer or any computer?

Mar 26, 2010 at 10:50 AM

The touchscreen is being detected by the windows, and it's working with the manipulationStarting and ManipulationDelta.

I haven't tried using another computer, but I don't think is the pc. The problem occurs when I'm a bit higher than the building. And to pan I have to press over the buildings, then you will have a weird behaviour. I fixed the problem, using in the manipulation events the same events than are being used by the mouse (when it's detected 1 touch). I'm sure I'm using your latest code. I'm using the Windows 7 and .Net 4.0 functionalities.

I still have some problems with the rotation.

 

I'm not sure how I can send you my changes, or even if you need them. But the imporve a lot the map with multitouch with 3D buildings.

 

Thank you for youe answer and help. I really appreciate it.

Apr 12, 2010 at 9:23 PM

I have the same issue. At first I thought it was due to the 3D buildings I have added, but then I went to the 3D buildings that are automatically added in Seattle and it behaves the same way.

If you tilt the map (so you are looking at the buildings at a slight angle), the pan feature almost stops working altogether.

Apr 13, 2010 at 7:07 PM
How can I turn this off? I actually *do* want to be able to "enter" buildings. It is a requirement for a project I'm working on. Thanks!
Jun 21, 2010 at 7:11 PM

Hey JoshB,

You said that "Panning near buildings is affected on purpose so you don't go into the building". How can I "disable" this? I don't want panning to be affected near buildings.

Thanks!

Coordinator
Jun 21, 2010 at 8:40 PM
kdavlin, There's no easy way to disable this behavior. It would involve writing a custom CameraController. Read these posts: http://blogs.msdn.com/b/virtualearth3d/archive/tags/camera/ and check the Bing Maps 3D Documentation: http://blogs.msdn.com/b/virtualearth3d/archive/2009/01/25/documentation.aspx